Get EA/Respawn to patch Apex legends POPCNT requirement

Get EA/Respawn to patch Apex legends POPCNT requirement

0 have signed. Let’s get to 2,500!
At 2,500 signatures, this petition is more likely to get picked up by local news!
Benjamin Sear started this petition to EA and

Apex legends currently does not support CPU's that do not contain the SSE4 instruction set, even though they are perfectly capable of running the game. Apex legends can boot and run horribly on my Pentium laptop but my PC with a dedicated GPU and 8Gb of RAM (that can play literally any other game at 1080p) can't play it because my CPU is a bit old???? Poor form from Respawn and EA to be honest. Other games have patched this in so its definitely possible.

0 have signed. Let’s get to 2,500!
At 2,500 signatures, this petition is more likely to get picked up by local news!