Petition Closed

To Make IOS7 Compatible with IPod 4th generation and other apple devices

This petition had 115 supporters


This is important because we paid for this apple device, we deserve all updates that apple throws out, the people with older devices should be treated the same as the people with the new ones



Today: Conner is counting on you

Conner Saxby needs your help with “IPhone Users: To Make IOS7 Compatible with IPod 4th generation and other apple devices”. Join Conner and 114 supporters today.