Tell DeviantART to not force Eclipse on us!

0 have signed. Let’s get to 35,000!


In May, DeviantART staff are retiring the old version of DA and forcing the new, unloved update Eclipse on users.(https://www.deviantartsupport.com/en/article/new-deviantart-launch-late-may Help stop this change and keep people where they are by signing. Thank you