Extend support to "old" Firefox addons

0 have signed. Let’s get to 100!


Some popular extensions for Firefox will stop working as of release of Firefox 57.

Example of popular extensions to be discontinued:

Classic Theme Restorer

Part of the text from addon description:

This add-on will stop working when Firefox 57 arrives in November 2017 and Mozilla drops support for XUL / XPCOM / legacy add-ons. It should still work on Firefox 52 ESR until ESR moves to Firefox 59 ESR in 2018 (~Q2).

DownThemAll!

Read the whole article: Re: DownThemAll and WebExtensions [… or why why I am done with mozilla]

FindBar Tweak

Read the author's message at: http://fasezero.com/

Related News: http://www.ghacks.net/2017/01/28/firefox-add-on-quicksaver-quits/

 

We need support for these extensions for at least 1-2 years longer.

 

A similar petition which is closed:

https://www.change.org/p/mozilla-don-t-remove-xul-and-xpcom-support-from-add-ons



Today: Ho Kuen is counting on you

Ho Kuen Leung needs your help with “Mozilla: Extend support to "old" Firefox addons”. Join Ho Kuen and 30 supporters today.